Dashboard 01 - Degraded Performance in Data Ingestion

Incident Report for MoEngage

Resolved

This incident has been resolved.
Posted Apr 21, 2026 - 01:45 UTC

Monitoring

We experienced a lag in our data ingestion pipeline between 8:00 AM UTC and 9:00 AM UTC due to an underlying system issue. A hotfix was deployed at approximately 8:45 AM UTC to address the problem.

The system is now operating normally and we are actively monitoring it. During the incident window, some processing lag accumulated, which is currently being cleared. We expect the backlog to be fully processed within the next two hours.

We apologize for the inconvenience caused and appreciate your patience while we worked to resolve the issue.
Posted Apr 20, 2026 - 10:34 UTC
This incident affected: dashboard-01 (Data Processing, Event Triggered Campaigns and Flows).