Service Outage

Incident Report for MoEngage

Resolved

This incident has been resolved.
Posted Feb 11, 2026 - 03:31 UTC

Update

We are continuing to monitor for any further issues.
Posted Feb 10, 2026 - 22:56 UTC

Monitoring

AWS has confirmed recovery of all their affected services. We are monitoring our services to ensure the services are back to normal.
Posted Feb 10, 2026 - 22:52 UTC

Update

We are continuing to investigate this issue with AWS as this may be affecting other regions (DCs/ Dashboards) due to issues in their global services like CloudFront.
Posted Feb 10, 2026 - 22:35 UTC

Investigating

We are currently experiencing a disruption affecting multiple services due to an ongoing outage with our cloud service provider, AWS. Our team is actively monitoring their status updates and collaborating with AWS to restore services as quickly as possible.

For more details on AWS’s status, please visit: https://health.aws.amazon.com/health/status
Posted Feb 10, 2026 - 22:10 UTC
This incident affected: dashboard-04 (In-app & On-site Messaging, Event Triggered Campaigns and Flows, Data APIs, Push APIs, Custom Segment API, Cards, Inform).