Degradation of Segmentation / Analytics Query Services on DC-01

Incident Report for MoEngage

Resolved

All systems are operational, our team will work on the RCA with the AWS team to prevent these incidents. Apologies for the inconvenience caused.
Posted Jul 19, 2022 - 06:32 UTC

Update

Campaigns are running in real time.
Posted Jul 19, 2022 - 06:28 UTC

Update

Dashboard segmentation queries are working.
Posted Jul 19, 2022 - 06:24 UTC

Update

We are prioritizing the campaign execution over dashboard queries at this time. You can go ahead and schedule the campaigns (if you want), even though you might not be seeing the segmentation query results.
Posted Jul 19, 2022 - 05:53 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jul 19, 2022 - 05:34 UTC

Identified

You might be experiencing delays / failures of some segmentation / analytics queries you run. Execution of some campaigns has also been delayed. This is due to the service degradation at our underlying infrastructure provider (AWS). Our team is working on the issue. Apologies for the inconvenience caused.
Posted Jul 19, 2022 - 05:20 UTC
This incident affected: dashboard-01 (One-time & Periodic Campaigns - Mobile Push & Web Push, Dashboard, Segmentation, Analytics (Analyze Capabilities)).