[DC-01] Lag in Periodic Segment Refresh

Incident Report for MoEngage

Resolved

This incident has been resolved.
Posted Apr 25, 2025 - 13:37 UTC

Update

The issue has been resolved. All the services are operational and continue to be monitored closely. We will work on the post-mortem and take corrective actions to avoid such issue in the future.
Posted Apr 25, 2025 - 13:37 UTC

Update

We are continuing to monitor for any further issues.
Posted Apr 25, 2025 - 12:48 UTC

Monitoring

The lag has been cleared. Services are back to normal. We are monitoring our systems.
Posted Apr 25, 2025 - 12:47 UTC

Update

The team has made progress to scale our infrastructure to burn the lag. The current lag will take another 2-3 hours to clear.
Posted Apr 25, 2025 - 11:09 UTC

Identified

Hi,

We are currently addressing a delay in the Periodic Segment Refresh on DC-01

This situation affects trigger-based campaigns, Flows, and Inbound Campaigns (In-App, OSM), as they are operating with outdated segments. However, rest assured that real-time campaigns, one-time campaigns, and dashboard segmentation queries are functioning normally.

Our team is actively working to resolve this issue promptly. We appreciate your patience and cooperation during this time.

We will keep updating the progress and try to resolve this soon.

If you have any questions, please don't hesitate to reach out to our support team.

Thank you,
Team MoEngage
Posted Apr 25, 2025 - 08:45 UTC
This incident affected: dashboard-01 (In-app & On-site Messaging, Event Triggered Campaigns and Flows).