[Dashboard-03] Delay in Ingestion Pipeline

Incident Report for MoEngage

Resolved

The issue is resolved as of now and ingestion pipeline latency seems stable. However, the technical team is root causing the issue to deploy a permanent fix.

This data ingestion delay had an impact on Smart trigger campaigns and Flows, as it consumes the data from the ingestion pipeline and apply trigger/flows conditions.

Delay of around 45 min lasted between 24-March 13:00 UTC to 15:40 UTC.
There were delay observed later as well on 24-March 20:30 UTC to 21:30 UTC.
Posted Mar 24, 2026 - 15:54 UTC

Identified

There is a delay of close to 45 min in DC-03 starting 13:00 UTC of users and events in our ingestion pipeline. We expect the issue to be resolved in another 45 min.
Posted Mar 24, 2026 - 14:47 UTC
This incident affected: dashboard-03 (Data Processing).