Dc03 | Data ingestion lag | Event processing

Incident Report for MoEngage

Resolved

This incident has been resolved.
Posted Mar 12, 2026 - 19:18 UTC

Identified

We are currently experiencing a delay in the data ingestion pipeline for following services:
1. Event Triggered Campaigns and Flows
2. Inbound Campaigns (In-App, OSM, WebP)
3. Recent Activity on User Profile

We have identified the issue and mitigation has been deployed and lag is being monitored closely by teams.
Posted Mar 12, 2026 - 17:05 UTC
This incident affected: dashboard-03 (In-app & On-site Messaging, Event Triggered Campaigns and Flows).