Event triggered flows and campaigns are still delayed. All the remaining services are operating normally. We will update here as soon as we have some meaningful progress.
Posted Oct 20, 2025 - 23:03 UTC
Monitoring
We have full capacity available from AWS now and we are focusing on bringing our degraded services back to normal.
Posted Oct 20, 2025 - 19:30 UTC
Update
Event triggered campaigns and Flows, Data processing, Campaign stats are running with a delay. All the other services are fully operational and working as expected. We will keep you updated on the progress.
Posted Oct 20, 2025 - 19:30 UTC
Update
We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 19:26 UTC
Update
We are seeing campaigns being sent in real time. Data processing is still lagging, we will keep you posted.
Posted Oct 20, 2025 - 19:18 UTC
Update
We have marked all campaigns that have been delayed considerably as stopped. If there are any campaigns that are critical, please duplicate and run them again. Campaigns are being processed in a controlled manner.
Posted Oct 20, 2025 - 17:31 UTC
Update
We are now beginning to process both older and new campaigns in a controlled manner. We ask that you please pause or stop any time-sensitive campaigns that should no longer be sent due to the delay. Please be aware that the AWS outage has also impacted our data processing pipelines, which will result in a delay in the visibility of campaign stats and event data in user profiles; you may not see analytics for recently run campaigns immediately. Our team's primary focus is to ensure all campaigns scheduled going forward are processed successfully, and we will post another update as soon as more information is available.
Inform campaigns are running as expected.
Posted Oct 20, 2025 - 16:58 UTC
Update
We're starting to process older and new batch (or one-time) campaigns in a controlled manner, please do pause / stop any campaigns that shouldn't be processed, as there's been a delay from the scheduled time due to the outage.
We're continuing to work with AWS, to fully restore our services.
Posted Oct 20, 2025 - 12:58 UTC
Update
We are continuing to work with our infrastructure provider, AWS, to fully restore all services. One-time campaigns remain affected, and our team is actively implementing an alternative solution to restore this functionality as quickly as possible. We will provide our next update by 1 PM UTC or sooner.
Posted Oct 20, 2025 - 12:06 UTC
Update
If you have any time‑sensitive campaigns that you do not want our auto‑heal systems to automatically rerun later, please pause or stop them now.
Posted Oct 20, 2025 - 10:19 UTC
Identified
Date/Time: October 20, starting at 7:00 AM UTC
We experienced a major outage in Dashboard 01 beginning at 7:00 AM UTC on October 20 due to an underlying issue with our cloud service provider (AWS, US East 1 region).
Impact:
- Dashboard logins were failing, which many customers reported. - Our status page tool was also affected, preventing us from posting an incident update immediately. - Twilio services were impacted, affecting customers using Twilio for SMS delivery.
Resolution & Current Status: Our engineering team has been actively working with AWS to fully resolve the outage. Services are now being restored - Inform service is operating normally, and we have retried all requests that failed earlier. Dashboard login is working now. Campaign services are still under recovery.
We will continue monitoring the situation closely and provide updates as new information becomes available.
We sincerely apologize for the disruption and thank you for your patience.