[Dashboard-02] Delay in Campaign Sending

Incident Report for MoEngage

Resolved

This incident has been resolved.
Posted Apr 24, 2026 - 05:27 UTC

Monitoring

There was a degradation in our querying service (Segmentation). The issue started at 3:00 UTC and is resolved now. We are now rerunning the failed campaigns. All delayed campaigns should be sent out in the next 45-60 minutes.
Posted Apr 24, 2026 - 04:35 UTC
This incident affected: dashboard-02 (One-time & Periodic Campaigns - Mobile Push & Web Push, One-time & Periodic Campaigns - Email, One-time & Periodic Campaigns - SMS, One-time & Periodic Campaigns - Connectors, One-time & Periodic Campaigns - Flows, Segmentation, One-time & Periodic Campaigns - Facebook Audience, One-time & Periodic Campaigns - WhatsApp, One-time & Periodic Campaigns - Google Ads Audience).