Campaign Drafts page isn't loading
Incident Report for MoEngage
Resolved
This incident has been resolved.
Posted Jul 14, 2022 - 05:21 UTC
Investigating
Campaign Drafts pages are not loading, and our team is investigating this issue. Apologies for the inconvenience caused.

As a workaround, Please find the Engage tab on the left main menu, click on the Drafts sub-menu, and then click on the campaigns tab once again to load the drafts. You can switch to the Flows tab and back to the campaigns tab to load the drafts.
Posted Jul 14, 2022 - 04:14 UTC
This incident affected: dashboard-01 (Dashboard).